Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

SBG Mobile and Internet Banking Experiencing Slow Response on Login
Incident Report for Standard Bank
Resolved
All our Internet and Mobile Banking services have now been fully restored. We apologise for the inconvenience caused.
Posted Feb 01, 2022 - 15:12 CAT
Identified
We are currently experiencing slow response times when customers attempt to log onto Internet Banking and the Mobile Banking App. We are working on resolving this. Customers who are not able to transact can use our Cellphone Banking by dialing *120*2345# and follow the prompts. Apologies for the inconvenience.
Posted Feb 01, 2022 - 08:48 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).