Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Our services on Online Banking and our mobile banking application are recovering
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 16:28 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2020 - 16:13 CAT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 29, 2020 - 16:07 CAT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2020 - 16:06 CAT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2020 - 16:05 CAT
This incident affected: Mobile Banking (App Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles) and Internet Banking (Internet Banking Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles).