Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Routine Maintenance on Digital Platform
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 05:30 CAT
Investigating
We are doing system maintenance from 23:00 until 04:00 AM (26 to 27 October 2021). Our Digital services will not be available during these times.

All other services will operate as normal (ATM, Card Swipes and Cellphone Banking)

This maintenance is essential to ensure our systems experience fewer disruptions to provide you with more reliable banking services. This is our top priority.

We apologise for any inconvenience caused.
Posted Oct 26, 2021 - 16:36 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).