Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

SBG Mobile Slow Response On Login
Incident Report for Standard Bank
Resolved
We are pleased to inform you that our Mobile Banking app has now been fully restored. We are sorry for the inconvenience caused.
Posted Feb 08, 2022 - 12:09 CAT
Identified
Standard Bank: You may be experiencing slow responses when logging onto our Mobile Banking App. We are working on resolving this urgently. Please use Internet Banking or Cellphone Banking as an alternative by dialling *120*2345#. We apologise for the inconvenience.
Posted Feb 08, 2022 - 11:44 CAT
This incident affected: Mobile Banking (App Login).