Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Incorrect balances reflecting on the Banking app
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 16:12 CAT
Investigating
Some of you may see incorrect balances on the banking app.We are currently working on a resolution, and we will keep you updated.We apologies for the inconvenience.
Posted Nov 10, 2020 - 15:49 CAT
This incident affected: Mobile Banking (View Balances).