Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Internet Banking Services Unavailable
Incident Report for Standard Bank
Resolved
Our Internet Banking login issue has been resolved. We thank you for your patience and apologise for any inconvenience caused.
Posted Oct 26, 2020 - 12:16 CAT
Update
We are continuing to monitor for any further issues.
Posted Oct 26, 2020 - 11:56 CAT
Update
We are continuing to monitor for any further issues.
Posted Oct 26, 2020 - 11:55 CAT
Monitoring
We have identified the login issue on Internet Banking and already seeing successful transactions on the channel. We are currently monitoring the results. We apologise for the inconvenience and will continue to keep you informed.
Posted Oct 26, 2020 - 11:52 CAT
Update
We are still working on restoring our login service on Internet Banking. Please use our Banking App or Cellphone Banking channel as an alternative in the interim. We sincerely apologise for the inconvenience and will continue to keep you informed.
Posted Oct 26, 2020 - 10:02 CAT
Identified
We are currently experiencing log in issues with internet banking.
Please use our mobile banking app and cellphone banking as alternatives while we resolve.
We apologise for any inconvenience caused.
Posted Oct 26, 2020 - 08:27 CAT
This incident affected: Internet Banking (Internet Banking Login).