Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Slow responses when logging in to Internet Banking
Incident Report for Standard Bank
Resolved
Our Internet Banking services are now fully restored. We thank you for your patience and apologise for any inconvenience caused.
Posted Oct 15, 2020 - 14:59 CAT
Investigating
You may be experiencing difficulties when trying to log into our Internet Banking service. We are sorting this out. Until then, please use our Banking App and Celphone Banking services as an alternative.

We apologise for any inconvenience and will keep you updated.
Posted Oct 15, 2020 - 13:59 CAT
This incident affected: Internet Banking (Internet Banking Login).