Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Mobile App
Incident Report for Standard Bank
Resolved
intermittent issues on our mobile app have been resolved. Thank you for your patience, and apologies for any inconvenience this has caused.
Posted Dec 19, 2021 - 11:34 CAT
Identified
You may be experiencing intermittent issues when attempting to log into our Mobile Banking App. Please use internet banking or *120*2345#on your mobile phone for Cellphone Banking. We apologise for the inconvenience caused.
Posted Dec 19, 2021 - 10:26 CAT
This incident affected: Mobile Banking (App Login).