Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Credit Card Tiles not Loading
Incident Report for Standard Bank
Resolved
All of our services have been restored, we apologies for the inconvenience and thank you for your patience.
Posted Mar 12, 2022 - 16:06 CAT
Identified
You may be experiencing issues accessing credit card tiles our Online Banking and Mobile Banking App. We are working to resolve this urgently. For real-time updates, register on statuspage.standardbank.co.za.
Posted Mar 12, 2022 - 15:38 CAT
This incident affected: Internet Banking (Account Tiles) and Mobile Banking (Account Tiles).