Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Multiple Service Impact: Internet Banking, Banking App, Cellphone banking, Point of Sale and ATM transactions failing
Incident Report for Standard Bank
Resolved
Earlier today you were not able to transact on our Banking App, Internet Banking, Cellphone Banking, Credit Cards, Point of Sale (POS) and ATMs. All services have now been fully restored. We sincerely apologise for the inconvenience caused.
Posted May 08, 2022 - 16:08 CAT
Update
We are continuing to investigate this issue.
Posted May 08, 2022 - 14:05 CAT
Update
We are continuing to investigate this issue.
Posted May 08, 2022 - 14:03 CAT
Investigating
We are currently investigating this issue.
Posted May 08, 2022 - 13:07 CAT
This incident affected: Cards and Payments (Point of Sale), ATM (Instant Money, Buy Airtime and Data), Cellphone Banking (Prepaid, Payments and Transfers, Balances, Lotto, Manage Debit Orders, Transaction History, Funeral Plan), Internet Banking (Account Tiles), and Mobile Banking (Account Tiles).