Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Intermittent slow responses across our Banking Services
Incident Report for Standard Bank
Resolved
You may have experienced intermittent access on some of our banking channels earlier. Our services have been restored. We apologise for any inconvenience and thank you for your patience.
https://statuspage.standard bank.co.za
Posted Jan 04, 2021 - 18:46 CAT
Investigating
You may be experiencing slow response times while using some of our Banking services. We are working on fixing the issues.

We apologise for any inconvenience and will keep you updated.
Posted Jan 04, 2021 - 14:21 CAT
This incident affected: Internet Banking (Internet Banking Login) and Mobile Banking (App Login).