Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Unable to access Mobile banking App and Internet banking
Incident Report for Standard Bank
Resolved
Standard Bank: Our Mobile and Internet Banking services have been fully restored following an interruption earlier today. We apologise for the inconvenience caused.
Posted Feb 12, 2023 - 14:54 CAT
Investigating
Standard Bank: You may be unable to access the Mobile Banking app, Internet Banking. Please use cellphone banking by dialling *120*2345# and ATMs as alternatives.  We are working on resolving this urgently and apologise for the inconvenience.
Posted Feb 12, 2023 - 13:23 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).