Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Instant Money Vouchers - Intermittent Failures
Incident Report for Standard Bank
Resolved
Services restored, we apologise for any inconvenience this may have caused.
Posted Jul 29, 2022 - 16:14 CAT
Identified
Instant money on Digital Platforms are failing intermittently. Our teams are currently investigating and working to restore services. We apologise for any inconvenience this may cause.
Posted Jul 29, 2022 - 14:30 CAT
This incident affected: Mobile Banking (Instant Money) and Internet Banking (Instant Money).