Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Slow responses on our digital channels
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 19:37 CAT
Update
We are continuing to investigate this issue.
Posted Feb 25, 2021 - 10:24 CAT
Investigating
You may be experiencing a challenge when trying to use our Digital Banking services. You can use our Cellphone Banking, swipe your card or use our ATMs as alternatives. We do apologize for the inconvenience caused and will keep you updated.
Posted Feb 25, 2021 - 10:18 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).