Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Our Mobile Banking App and Internet banking services are unavailable
Incident Report for Standard Bank
Resolved
Our Banking App and Internet Banking login issue has been resolved.

We thank you for your patience and apologise for the inconvenience.

https://statuspage.standardbank.co.za
Posted Nov 14, 2020 - 08:46 CAT
Investigating
You may be experiencing issues logging in to our Banking App and Internet Banking channels. We are sorting this out. Until then, please use our Cellphone banking service as an alternative.

We apologise for any inconvenience and will keep you updated.

https://statuspage.standardbank.co.za
Posted Nov 14, 2020 - 08:00 CAT
This incident affected: Internet Banking (Internet Banking Login) and Mobile Banking (App Login).