Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Lotto and Prepaid Electricity Transactions not available
Incident Report for Standard Bank
Resolved
Our Lotto and Prepaid Electricity services are now fully functional. We thank you for your patience and apologise for any inconvenience caused.
Posted Oct 23, 2020 - 14:44 CAT
Investigating
You will not be able to play Lotto or buy Prepaid Electricity on our Banking App, Internet and Cellphone Banking platforms at the moment. We are sorting this out. We apologise for any inconvenience and will keep you updated.
Posted Oct 23, 2020 - 13:31 CAT
This incident affected: Mobile Banking (Buy Electricity, Play Lotto) and Internet Banking (Buy Electricity, Play Lotto).