Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Mobile Banking App log in issues
Incident Report for Standard Bank
Resolved
We are pleased to advise that our Mobile Banking services have been restored. We thank you for your patience and apologise for any inconvenience caused.

https://statuspage.standardbank.co.za
Posted Apr 16, 2021 - 14:03 CAT
Investigating
You may have trouble logging into our Mobile Banking App due to a technical issue. We are working to resolve this urgently. Please use Internet Banking or Cellphone Banking in the interim. We apologise for any inconvenience caused.

https://statuspage.standardbank.co.za
Posted Apr 16, 2021 - 11:51 CAT
This incident affected: Mobile Banking (App Login).