Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Banking App and Internet Banking
Incident Report for Standard Bank
Resolved
Earlier today Standard Bank experienced technical issues on its Banking App and Internet Banking application. These services have been restored, and customers can now access and use Internet Banking and the Mobile App.
Our technicians worked tirelessly to restore services to these banking channels. Regrettably, efforts to restore these services to their full functionality took longer than expected. For this we sincerely apologise. No other banking channels were impacted.
Posted Dec 09, 2021 - 17:05 CAT
Update
We are continuing to investigate this issue.
Posted Dec 09, 2021 - 11:54 CAT
Update
We are continuing to investigate this issue.
Posted Dec 09, 2021 - 11:42 CAT
Update
We are continuing to investigate this issue.
Posted Dec 09, 2021 - 11:41 CAT
Investigating
We are aware that you may be experiencing difficulties logging on to some of our digital channels. Our technical teams are working to resolve the issue as soon as possible. Please dial *120*2345#on your mobile phone for Cellphone Banking. We apologise for the inconvenience caused.
Posted Dec 09, 2021 - 11:38 CAT
This incident affected: Internet Banking (Internet Banking Login) and Mobile Banking (App Login).