Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Telecoms Services Providers Outrage Experienced
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 18:20 CAT
Investigating
One of Standard Bank’s telecoms providers has experienced technical difficulties this morning. As a consequence some Standard Bank services to its clients may have been impacted or delayed. These include:

* OTP delayed delivery
* Delays in receiving MyUpdates
* Slower response times when contacting the Standard Bank Call Centre

The telecoms provider is currently restoring its services. We apologise for the inconvenience.
Posted Jan 13, 2021 - 12:01 CAT