Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Lotto transactions-Intermittent Errors

Incident Report for Standard Bank

Resolved

This incident has been resolved.
Posted Apr 08, 2022 - 21:03 CAT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2022 - 18:57 CAT

Investigating

We are currently investigating this issue.
Posted Apr 08, 2022 - 18:49 CAT
This incident affected: Mobile Banking (Play Lotto) and Internet Banking (Play Lotto).