Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Difficulty accessing Mobile Banking App and Internet Banking
Incident Report for Standard Bank
Resolved
Earlier today you may have experienced difficulty when trying to access our Mobile Banking App, Internet Banking and performing card transactions. All banking services are now fully operational. We apologise for the inconvenience caused.
Posted May 23, 2023 - 19:39 CAT
Identified
You may be experiencing difficulty when trying to access our Mobile Banking App, Internet Banking. Please use cellphone banking by dialling *120*2345# or ATMs in the interim. We are working on resolving this urgently and apologise for the inconvenience.
Posted May 23, 2023 - 17:28 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).