Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Customers may experience slow response times on the Mobile banking App
Incident Report for Standard Bank
Resolved
Kindly note that this matter has now been resolved. We do apologise for any inconvenience that may have been caused.
Posted Aug 03, 2021 - 14:28 CAT
Identified
You may experience slow responses on the mobile banking app. We are working on the issue and hope to have it resolved shortly.
Posted Aug 03, 2021 - 09:36 CAT
This incident affected: Mobile Banking (Account Tiles).