Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Some customers may be experiencing intermittent delay in receiving OTP notifications
Incident Report for Standard Bank
Resolved
Earlier mobile network providers experienced difficulties delivering OTP to some of our customers. This issue has now been resolved. We apologise for the inconvenience.
Posted Jun 01, 2021 - 15:08 CAT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2021 - 14:40 CAT
Investigating
Some of our customers may be experiencing an intermittent delay in receiving OTP messages. The mobile network provider's technical teams are working to resolve the problem soonest. We apologise for the inconvenience caused.
Posted Jun 01, 2021 - 14:38 CAT