Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Internet Banking Currently Unavailable
Incident Report for Standard Bank
Resolved
Earlier today you were unable to login to Internet Banking or do Mobile App new registrations. All services have now been fully restored. We sincerely apologise for the inconvenience caused.
Posted May 09, 2022 - 09:19 CAT
Identified
Standard Bank: We regret that you may not be able to login into Internet Banking or do Mobile Banking App new registrations. We are working on resolving this urgently. Please use Mobile Banking App for your banking or Cellphone Banking as an alternative by dialling *120*2345#. We apologise for the inconvenience.
Posted May 09, 2022 - 09:04 CAT
This incident affected: Internet Banking (Internet Banking Login).