Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Apple Pay unavailable to certain customers
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 12:36 CAT
Investigating
Due to a system update, your Apple Pay functionality may have been deactivated. Please reactivate your card to gain full access to the services. We sincerely apologise for the inconvenience that this has caused.”
Posted Mar 17, 2022 - 09:31 CAT
This incident affected: Cards and Payments (Apple Pay).