Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Internet Banking, Mobile Baking App, Cellphone Banking and Card problems.
Incident Report for Standard Bank
Resolved
Earlier today you may not have been able to use your card for any transactions at point of sale, intermittent issues when accessing Internet Banking, mobile banking and cellphone banking. All systems have fully recovered, we apologise for the inconvenience caused
Posted Nov 20, 2022 - 09:11 CAT
Identified
You will not be able to use your card for any transactions at point of sale. You may also experience intermittent issues when accessing Internet Banking, mobile banking and cellphone banking. Please use ATMs to withdraw cash as an alternative. We are working on resolving this urgently and apologise for the inconvenience.
Posted Nov 20, 2022 - 08:42 CAT
This incident affected: Mobile Banking (App Login), Internet Banking (Internet Banking Login), and Cards and Payments (Point of Sale, Standard Bank Card Swiping).