Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Unable to log into the Mobile Banking App
Incident Report for Standard Bank
Resolved
This incident has been resolved and we are currently monitoring it.
Posted Mar 25, 2021 - 09:14 CAT
Identified
You may have trouble logging into our Mobile Banking App due to a technical issue. We are working to resolve this. Please use internet banking or Cellphone Banking while we resolve. We do apologise for any inconvenience caused.
Posted Mar 25, 2021 - 08:29 CAT
This incident affected: Mobile Banking (App Login).