Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Standard Bank Simmonds Street Campus Inaccessible
Incident Report for Standard Bank
Resolved
The Standard Bank’s Simmonds Street complex in Johannesburg CBD which was closed today after fire broke out at its Energy Management Centre early this morning is now safe to occupy. The building will re-open tomorrow.

The bank’s engineers and real estate personnel were able to contain the situation. While repairs are underway, there are sufficient redundancies in the building’s energy management systems to ensure that adequate energy coverage is maintained. The City of Johannesburg Emergency Services have declared the building safe for occupation.

We have established that the cause of the fire was loadshedding which put a strain on physical components related to energy management and distribution to the Simmonds Street Campus.

All the bank’s back-up and safety features housed within the Energy Management Centre - including fire detection, emergency system by-pass and response - proved resilient and operated as expected, thus minimizing damage, and allowing for a speedy and efficient recovery of services.

The bank wishes to extend an apology to its clients and employees who were inconvenienced by the incident.
Posted Jul 12, 2022 - 15:41 CAT
Monitoring
Standard Bank’s Simmonds Street complex in the Johannesburg CBD has been closed for the day due to a fire in the facility’s Energy Management Centre. No injuries were suffered, and the city’s emergency services department has extinguished the fire.

While the investigations are still underway, initial assessments indicate that the cause of the fire was technical in nature, and not due to a human factor.

The fire was contained to the energy centre, with no further damage to the rest of the building other than smoke damage. Staff have been informed that the building has been closed and will be accommodated in other Standard Bank facilities where appropriate or work from home until further notice.
Customers can expect services to be delayed in some instances as the bank moves staff to alternate worksites.

We apologise for the inconvenience that this is causing, and further updates will be provided as required.
Posted Jul 12, 2022 - 13:06 CAT
This incident affected: Digital Banking Helpdesk and Voice Branch / Call Centre 0860123000.