We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.
Get email notifications whenever Standard Bank creates, updates or resolves an incident.
Get text message notifications whenever Standard Bank creates or resolves an incident.
Get webhook notifications whenever Standard Bank creates an incident, updates an incident, resolves an incident or changes a component status.
Standard Bank’s Internet Banking and Business Online platforms are fully operational after an interruption experienced this morning. During the interruption, customers were able to use the mobile banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We apologise for the inconvenience caused.
Posted Oct 18, 2022 - 12:56 CAT
Update
Standard Bank’s Internet Banking and Business Online platforms are fully operational after an interruption experienced this morning. During the interruption, customers were able to use the mobile banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We apologise for the inconvenience caused.
Posted Oct 18, 2022 - 12:54 CAT
Update
Standard Bank: Business Online services are available following a fix. Customers are still unable to access Internet Banking. Please continue to direct customers to use Mobile Banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We are working on resolving this urgently and apologise for the inconvenience caused.
Posted Oct 18, 2022 - 11:34 CAT
Identified
Standard Bank: You may be unable to access Internet Banking and Business Online. Please use Mobile Banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We are working on resolving this urgently and apologise for the inconvenience.
Posted Oct 18, 2022 - 11:04 CAT
This incident affected: Internet Banking (Internet Banking Login) and Business Online.