Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Payments failure on digital channels and ATM's experienced
Incident Report for Standard Bank
Resolved
Services on payments failures are fully restored. We sincerely apologise for the disruption to banking services
Posted May 03, 2021 - 17:41 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2021 - 17:28 CAT
Identified
The issue has been identified and a fix is being implemented.
Posted May 03, 2021 - 17:23 CAT
Investigating
Some customers may not be able to process payments, purchase recharge vouchers and some ATM payment failures may also be experienced
Posted May 03, 2021 - 16:50 CAT
This incident affected: Internet Banking (Buy Airtime and Data, Buy Electricity, Play Lotto) and Mobile Banking (Buy Airtime and Data, Buy Electricity, Play Lotto).