Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Intermittent login errors when accessing Internet banking and Mobile App
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted May 06, 2022 - 17:12 CAT
Investigating
We are currently investigating this issue.
Posted May 06, 2022 - 16:00 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).