Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Immediate Payments to Nedbank - Currently unavailable.
Incident Report for Standard Bank
Resolved
Service restored at 15:27
Posted Jun 15, 2022 - 15:35 CAT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2022 - 14:54 CAT
Investigating
Immediate payments to Nedbank currently unavailable. We apologise for any inconvenience this may cause
Posted Jun 15, 2022 - 14:53 CAT
This incident affected: Cards and Payments (Real Time Clearance).