Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

One Time Password Slow Response
Incident Report for Standard Bank
Resolved
The slow or intermittent disruption to the delivery of One Time Passwords has been resolved. We apologize for any inconvenience this may have caused you.
Posted Nov 08, 2021 - 13:35 CAT
Identified
We are currently experiencing slow, or intermittent disruption to the delivery of One Time Passwords. To complete a transaction please give it a few min before attempting the transaction again. Apologies for the inconvenience.
Posted Nov 08, 2021 - 09:36 CAT
This incident affected: Mobile Banking (Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto) and Internet Banking (Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto).