Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Real Time Clearance Delays
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Jun 26, 2021 - 06:16 CAT
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2021 - 13:02 CAT
Identified
We are currently experiencing delays in processing immediate payments to partner banks. Our teams are working hard to resolve this soonest. We appreciate your patience and apologise for any inconvenience caused.
Posted Jun 25, 2021 - 13:02 CAT