Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Mobile Banking App Unavailable
Incident Report for Standard Bank
Resolved
All services on our Mobile Banking App is now fully restored. You may have experienced slow or intermittent access during the course of today. We sincerely apologise for any inconvenience this may have caused you.
Posted Aug 31, 2021 - 16:25 CAT
Update
You may still be experiencing slow or intermittent access with our Mobile Banking App, we are still working to resolve this urgently. We thank you for your patience. We apologise for any inconvenience this may have caused and will keep you updated.
Posted Aug 31, 2021 - 13:02 CAT
Update
You may be experiencing slow or intermittent responses when attempting to log into our Mobile Banking App. We are working to resolve the issue and apologise for the inconvenience it has caused. We will continue to update you.
Posted Aug 31, 2021 - 09:17 CAT
Identified
You may be experiencing problems while transacting on our Banking app, as some of your account tiles are currently not available. Our Internet Banking, Cellphone Banking, and all other services are still available. We are working on fixing the issue, we apologies for any inconvenience and will keep you updated.
Posted Aug 31, 2021 - 08:07 CAT
This incident affected: Mobile Banking (App Login).