Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Real Time Clearance to Capitec
Incident Report for Standard Bank
Resolved
Real Time Clearance to Capitec has been resolved. We apologise for any inconvenience that was caused.
Posted Feb 25, 2022 - 16:27 CAT
Identified
We are currently experiencing Real Time Clearance to Capitec. Our teams are working hard to resolve this soonest. We appreciate your patience and apologise for any inconvenience caused.
Posted Feb 25, 2022 - 15:47 CAT
This incident affected: Cards and Payments (Real Time Clearance).