Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Ucount tile, Prepaid electricity, Manage cards , EAP Limits, Home Services Tile, Lotto & Insurance tile are currently none functional
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted May 01, 2022 - 13:57 CAT
Investigating
We are currently investigating this issue.
Posted May 01, 2022 - 09:25 CAT
This incident affected: Cellphone Banking (Prepaid, Lotto), Mobile Banking (Buy Electricity, Play Lotto, UCount), and Internet Banking (Buy Electricity, Play Lotto).