Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Unable to pay with your Debit or Cheque card
Incident Report for Standard Bank
Resolved
Earlier today you may have experienced difficulty using your Debit or Cheque cards. All card services have been fully restored. We apologise for any inconvenience caused.
Posted Apr 15, 2023 - 10:24 CAT
Identified
Standard Bank: You may be experiencing difficulty when trying to pay with your debit or cheque cards. You can use credit card, Mobile Banking app, Internet Banking or instant money as alternatives. We are working on resolving this urgently and apologise for the inconvenience.
Posted Apr 15, 2023 - 09:46 CAT
This incident affected: Cards and Payments (Point of Sale, Standard Bank Card Swiping) and ATM (ATM Card Declining).