We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.
Get email notifications whenever Standard Bank creates, updates or resolves an incident.
Get text message notifications whenever Standard Bank creates or resolves an incident.
Get webhook notifications whenever Standard Bank creates an incident, updates an incident, resolves an incident or changes a component status.
We are continuing to work on a fix for this issue.
Posted May 21, 2022 - 11:50 CAT
Identified
You may be experiencing intermittent issues when using your card at Point of Sales devices and ATMs. We are working hard to fix this and apologise for the inconvenience caused.
Posted May 21, 2022 - 08:54 CAT
This incident affected: ATM (Instant Money) and Cards and Payments (Point of Sale, Standard Bank Card Swiping).