Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Some Android Device holding customers are experiencing issues accessing our banking app
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 10:10 CAT
Monitoring
Customers experiencing issue to go through the following process;
1: Go to Android playstore
2: Search & Install/Update Android system webviews

Note: Customer should be able to access banking app once process is completed
Disclaimer: This is not a Standard Bank app issue, rather an Android system issue impacting certain devices
Posted Mar 23, 2021 - 10:03 CAT
This incident affected: Mobile Banking (App Login, View Balances, Account Tiles).