Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

IT3b's (Tax Certificates) unavailable on our Digital platforms for some customers
Incident Report for Standard Bank
Resolved
Customers are now able to download the IT3b tax certificates on the banking app and internet banking.
We apologise for any inconvenience caused.
Thank you for your patience.
Posted Jul 14, 2021 - 12:30 CAT
Identified
We are working urgently to resolve the technical issues you may be experiencing while trying to download your 2021 tax certificates (IT3b), on our Mobile banking App and Internet Banking service. We apologise for any inconvenience this has caused and will keep you updated.
Posted Jul 07, 2021 - 15:17 CAT
This incident affected: Mobile Banking (Banking statement) and Internet Banking (Banking Statements).