Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Customers experiencing issues accessing digital services and the voice branch (call centers)
Incident Report for Standard Bank
Resolved
You may have experienced issues transacting on our banking channels earlier. Our services have been restored and we apologise for the inconvenience. Thank you for your patience.
Posted Dec 07, 2020 - 18:22 CAT
Monitoring
Our services are in the process of recovering. Our technical teams will continue to monitor the situation.
Customers are able to transact on our digital channels as well as voice banking and ATM’s. We apologise for the inconvenience.
Posted Dec 07, 2020 - 17:49 CAT
Investigating
You may be experiencing problems while transacting on our Mobile Banking App, Internet Banking, Cellphone Banking and the voice branch.
We have limited services available on ATM's (withdraw and Balance inquiry), Point of Sale (PoS) transactions are also available.
We are working on fixing the issues and apologise for any inconvenience caused. We will keep you updated.
Posted Dec 07, 2020 - 16:43 CAT
This incident affected: Internet Banking (Internet Banking Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles) and Mobile Banking (App Login, View Balances, Instant Money, Buy Airtime and Data, Buy Electricity, Play Lotto, Account Tiles).