Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Lotto Feature Currently Unavailable
Incident Report for Standard Bank
Resolved
Services restored at 15:14
Posted Jun 10, 2022 - 16:01 CAT
Identified
You may be experiencing failures when purchasing Lotto tickets on our Digital Platforms at the moment. We are working hard to fix this and apologise for the inconvenience caused.
Posted Jun 10, 2022 - 15:14 CAT
This incident affected: Mobile Banking (Play Lotto) and Internet Banking (Play Lotto).