Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

EAP limit increase on Internet Banking and Mobile App Banking Slow Response
Incident Report for Standard Bank
Resolved
The service has been restored.
Thank you for your patience.
Posted Oct 16, 2020 - 16:19 CAT
Identified
You may be experiencing issues increasing EAP limits on Internet Banking and mobile banking app. We are sorting this out and apologise for any inconvenience caused.
Posted Oct 16, 2020 - 15:22 CAT
This incident affected: Mobile Banking (Account Tiles) and Internet Banking (Account Tiles).