Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Lotto
Incident Report for Standard Bank
Resolved
Lotto Feature enhancements have been resolved.We apologize for any inconvenience this may cause.
Posted Feb 25, 2022 - 17:47 CAT
Update
We are continuing to work on a fix for this issue.
Posted Feb 25, 2022 - 17:46 CAT
Identified
Our objective is to offer you services that will make banking convenient and offer a better experience.
Our LOTTO feature is currently going through enhancements. The technical team is vigorously working on resolving the matter. We apologize for any inconvenience this may cause.
Posted Feb 25, 2022 - 17:16 CAT
This incident affected: Mobile Banking (Play Lotto) and Internet Banking (Play Lotto).