Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Digital Channels Unavailable (Internet Banking and Mobile App)
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 11:03 CAT
Investigating
Our Digital services will not be available until 10h00am. All other services will operate as normal (ATM’s, Card Swipes and Cellphone Banking).

This maintenance is essential to ensure our systems experience fewer disruptions. We apologise for any inconvenience caused.
Posted Oct 27, 2021 - 09:12 CAT
This incident affected: Internet Banking (Internet Banking Login) and Mobile Banking (App Login).