Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Account tiles not loading
Incident Report for Standard Bank
Resolved
All of our services have been restored, we apologies for the inconvenience and thank you for your patience.
Posted Nov 24, 2020 - 22:25 CAT
Update
We are continuing to work on a fix for this issue.
Posted Nov 24, 2020 - 22:22 CAT
Identified
You may be experiencing problems while transacting on our Banking app, Internet banking , Cell Phone banking and ATM'S as some of your account tiles are currently not available. We are working on fixing the issue, we apologies for any inconvenience and will keep you updated.
Posted Nov 24, 2020 - 21:24 CAT
This incident affected: Mobile Banking (Account Tiles) and Internet Banking (Account Tiles).