Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Unable to Log into Internet Banking
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted Apr 23, 2021 - 19:42 CAT
Update
Internet Banking and Banking App are recovering and we continue to monitor
Posted Apr 23, 2021 - 18:51 CAT
Monitoring
We previously communicated that our customers were having intermittent difficulties accessing our Mobile Banking App and Internet Banking. Services to those platforms are now in the process of recovering. Again we apologise for the inconvenience and frustration this has caused. We will continue to monitor these services throughout the night to ensure our service to you remains exceptional.
Posted Apr 23, 2021 - 18:36 CAT
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2021 - 16:06 CAT
Update
You may be experiencing issues when logging into Internet Banking and our Mobile Banking app. We are working to resolve this urgently. Please use Cellphone Banking as alternatives. We apologise for any inconvenience caused
Posted Apr 23, 2021 - 11:18 CAT
Identified
You may be experiencing issues when logging into Internet Banking. We are working to resolve this urgently. Please use Mobile Banking App or Cellphone Banking as alternatives. We apologise for any inconvenience caused.
Posted Apr 23, 2021 - 10:04 CAT
This incident affected: Mobile Banking (App Login) and Internet Banking (Internet Banking Login).