Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Mobile Banking App , Internet Banking and ATM not available
Incident Report for Standard Bank
Resolved
This incident has been resolved.
Posted May 02, 2021 - 14:05 CAT
Update
We identified a hardware issue that impacted our Mobile App, Internet Banking and ATMs. The issue has now been resolved and services across all banking channels are now fully restored. We apologise for the frustration that such disruptions cause you
Posted May 02, 2021 - 14:04 CAT
Update
We are still working urgently to resolve the technical issues you may are experiencing while trying to transact on our Mobile Banking App, Internet Banking. ATM's and Point of Sale services are fully restored. Please use Cellphone banking (*120*2345# ) in the interim. We apologise for any inconvenience caused.
Posted May 02, 2021 - 12:33 CAT
Identified
We are working urgently to resolve the technical issues you may be experiencing while trying to transact on our Mobile Banking App, Internet Banking and ATMs. Please use Cellphone banking (*120*2345# ) in the interim. We apologise for any inconvenience caused.
Posted May 02, 2021 - 11:13 CAT
This incident affected: Internet Banking (Internet Banking Login) and Mobile Banking (App Login).