Service status | Standard Bank

Standard Bank Service Status

We do everything we can to make sure the services you need are always online. If, however, one of our services is not working correctly or down, you can find out what's happening here. Keep checking back, we work hard at solving problems that may occur.

Customer are not able to access the SBG Mobile App
Incident Report for Standard Bank
Resolved
We are pleased to advise that our Mobile Banking services have been restored. We apologise for any inconvenience caused
Posted Mar 26, 2021 - 11:30 CAT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2021 - 09:02 CAT
Update
We are pleased to advice that services on our mobile banking app have been restored. You can now login for your banking. Thank you for your patience
Posted Mar 26, 2021 - 08:48 CAT
Update
You may have trouble logging in to our mobile banking app. We are working on resolving the problem. Kindly use internet banking or cellphone banking while we resolve. We apologise for the inconvenience caused
Posted Mar 26, 2021 - 08:34 CAT
Identified
You may be experiencing problems while transacting on our Mobile Banking app as some of your account tiles are not available. We are working on resolving the problem. Kindly use Internet banking or Cellphone banking while we resolve. We do apologise for any inconvenience caused.
Posted Mar 26, 2021 - 08:13 CAT
This incident affected: Mobile Banking (App Login).